Account management issues
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 14:54 CDT
Identified
We are currently experiencing issues with BigCommerce account management due to an incident with a third party provider. This includes the ability to purchase services in the Account Dashboard and create new trial stores. BigCommerce engineers are monitoring the incident and will provide updates as they become available.
Posted Sep 04, 2024 - 14:05 CDT
This incident affected: Control Panel.