Cannot reach checkout payment step

Incident Report for BigCommerce

Resolved

Commerce engineers have identified the issue and rolled out a fix for it, we have verified the functionality has been restored.
Posted Dec 28, 2025 - 21:21 CST

Investigating

Commerce engineers have received reports of some customers experiencing issues with payment setup during checkout, we're investigating the issue
Posted Dec 28, 2025 - 21:00 CST
This incident affected: Checkout & Payment Processing.