Intermittent Availability Issues

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 08:18 CST

Monitoring

All stores are now accessible
Posted Dec 30, 2025 - 06:50 CST

Update

We have restored service for approximately 50% of affected stores, and are working on restoring service for the remaining stores.
Posted Dec 30, 2025 - 06:41 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 30, 2025 - 06:26 CST

Update

We are continuing to investigate this issue.
Posted Dec 30, 2025 - 06:07 CST

Investigating

BigCommerce engineers are currently investigating intermittent availability issues with a subset of stores in the US region. We will provide an update shortly.
Posted Dec 30, 2025 - 05:41 CST
This incident affected: Control Panel and Storefront.