B2B Merchant Login

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 12:00 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2026 - 11:58 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 06, 2026 - 11:58 CST

Update

We are continuing to investigate this issue.
Posted Jan 06, 2026 - 11:42 CST

Update

We are continuing to investigate this issue.
Posted Jan 06, 2026 - 11:41 CST

Investigating

Commerce engineers observed an intermittent issue with merchant login to B2B Merchant Dashboard. We are currently investigating the cause.
Posted Jan 06, 2026 - 11:38 CST
This incident affected: B2B Edition (B2B Edition - Dashboard).