B2B Ninja Quote emails are failing to send

Incident Report for BigCommerce

Resolved

The email issue affecting B2B Ninja is resolved and quotes are sending normally again.

Quotes sent during the outage (June 29, 2026, 10:00 PM UTC – July 1, 2026, 6:00 AM UTC) may not have gone out. They appear in the dashboard, but the customer may see them stuck as "pending" on the storefront.

To fix an affected quote: open it, click Edit, then click Send Quote. This re-sends the email and restores the customer's view. Quotes already showing as sent need no action.

We apologize for the disruption. If a quote still looks wrong after re-sending, contact support.
Posted Jul 01, 2026 - 11:00 CDT

Monitoring

The issue has been identified and resolved by the third party email service and functionality is restored. We're working on re-triggering the emails that were not sent during this outage.
Posted Jul 01, 2026 - 01:00 CDT

Update

The issue remains under active escalation with the third-party email provider. We're working with their team and will provide updates as soon as they are available.
Posted Jul 01, 2026 - 00:15 CDT

Update

The issue is still under active escalation with the third-party email service provider. We continue to work closely with their team and will share updates as they become available.
Posted Jun 30, 2026 - 20:36 CDT

Update

We are continuing to work with the third party email service to get this resolved. The escalation is still ongoing.
Posted Jun 30, 2026 - 17:59 CDT

Update

We've escalated the issue to our third party email service. We're working with them to get this resolved.
Posted Jun 30, 2026 - 13:24 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 30, 2026 - 12:50 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 30, 2026 - 11:11 CDT

Investigating

We are currently investigating this issue.
Posted Jun 29, 2026 - 05:00 CDT
This incident affected: Email.